OTIS Browser Requirements

Please note:  OTIS was designed to work with Internet Explorer (IE) browser versions 6.0 through 9.0.  OTIS is not compatible with IE browser versions 10 or higher.

To use OTIS with Internet Explorer versions higher than 9.0:

Open the OTIS Production website, click on Tools, (if Tools is not available, click on the "cog" on the far right at the top of the screen), click on "Compatibility View Settings".  Find "Display all websites in Compatibility View" and insert a check mark.  If "Display all websites in Compatibility View" is already checked &/or you continue to receive the error message, cut and paste the OTIS URL (web address) under "Add this website" then click "Add".  If Louisiana.gov is already in the box under "Add this website", click Add.  Click on Close.

OTIS has not been tested using other browsers (Mozilla Firefox, Safari, Chrome, etc.)